Thursday, November 19, 2009

VMware VSphere Client ERRORs on Windows 7 64bit

Error Messages:
1. Error parsing the server “hostname”“clients.xml” file.Login will continue, contact your system administrator
2. The type initializer for 'VirtualInfrastructure.Utils.HttpWebRequestProxy' threw an exception
Nothing will happen after you click "OK" on above errors.

Don't take a deep breath and panic. ;) follow these easy steps to resolve these errors withing 10 min.

1. You need to get a copy of following DLL file from computer which has installed .NET 3.5 SP1. The file name is System.dll and it's located in %SystemRoot%\Microsoft.NET\Framework\v2.0.50727\

Please Note: Getting this DLL from 32 bit system is fine but not from Windows 7 or Win 2008 versions.
I have uploaded this file for you : http://www.easy-share.com/1908477347/System.dll

2. Create a folder and copy this DDL file to some where in "C:\Program Files (x86)\VMware\Infrastructure\Virtual Infrastructure Client\Launcher" for this example I have created "bug" and copied the DLL inside it.

3. And please find the file named VpxClient.exe.config in the same folder which you have created the folder in action 2 (C:\Program Files (x86)\VMware\Infrastructure\Virtual Infrastructure Client\Launcher) Open the particular file and include following lines before the end and without "" and save. (if you can't save the file get the ownership for the current user by using file properties >> Security >> Advanced... )

"


"

4. Now you need to make Environment Variable for the DDL file show in the screen shot below
Variable name: DEVPATH
Variable value: C:\Program Files (x86)\VMware\Infrastructure\Virtual Infrastructure Client\Launcher\bug\
That's all and now you are ready to go !

Wednesday, November 11, 2009

More Demilitarized Zones on VMware


You may have a requirement to maintain more than one DMZ zones due to high security situations. In this easy example you can get a basic idea of deploying many DMZs.(as much as your hardware supports). Since VMware VSphere came to the picture there will be many scenarios of performing this but here I used Cisco ASA series firewall (you can use even ASA 5505 or with old PIX series), HP ProCurv manageable switch and VMware ESXi host.

Let's start form the Firewall. You need to have minimum of three interfaces to perform this operation, and one interface will be your DMZ interface and for that interface I used following Trunking configuration on "Ethernet0/2" ;
!
interface Ethernet0/2
no nameif
no security-level
no ip address
!
interface Ethernet0/2.1
vlan 10
nameif dmz1
security-level 50
ip address 192.168.10.254 255.255.255.0
!
interface Ethernet0/2.2
vlan 20
nameif dmz2
security-level 50
ip address 192.168.20.254 255.255.255.0
!

And now you need to acknowledge your switch about this VLAN tagging in order to correct switching the same tagged packets. Configuration will be easy and I did as following;

vlan 20
name "VLAN20"
tagged 13,15
no ip address
exit
vlan 10
name "VLAN10"
tagged 13,15
no ip address
exit
And now you need to create a Vswitch in the VMware host, binding the external interface you planing use for this deployment. Check below example diagram;


Now you are almost done, basically you can control the internal access (security) using a third party firewall as shown like following digram.


I have assigned a easy IP structure for you to understand this setup easily.

Friday, October 16, 2009

How to add Flash plugin to Google Crome

Recently Google Chrome has became my favorite browsers but nothing happens when when you install Flash plugin. So you will need to manually install it. Very simple procedure.

1. Download http://fpdownload.macromedia.com/get/flashplayer/xpi/current/flashplayer-win.xpi

2. No need to fear with the file extension, simply rename flashplayer-win.xpi to flashplayer-win.xpi.zip then your ZIP program will do the job for you

3. Extract the file and copy two file named “flashplayer.xpt” and “NPSWF32.dll”

4. Past above to files in to C:\Users\YOURUSERNAME\AppData\Local\Google\Chrome\Application\Plugins (in Vista)
and create a folder name Plugin is it's not exists

C:\Documents and Settings\YOURUSERNAME\Local Settings\Application Data\Google\Chrome\Application\Plugins (in Win XP)

5. Restart the Browser and now you are done.

Thursday, May 21, 2009

The basic concept of troubleshooting

In my younger times my Dad had an electrical workshop in Batticolo (1980 ~ 1985).

One day I hardly remember someone came with an electrical iron and he wanted to fix it because it’s was not working. My Dad had about 10 tech workers in the workshop and a one of a newbie worker has assigned for these kinds of small tasks. (I’m very interested to spend the time in my Dad’s workshop so I was seeing these stories from the beginning)
So, he has removed the front cover of the iron ASAP and replaced the iron element with no delays. But it’s not worked, so he has spend some hours finding where the issue is and finally he decided to get advice from my father and my Dad just asked him to check the fuse in the power plug at the end.

Replacing the fuse has resolved the issue and it worked well with the existed iron element as well. So my Dad has been taught his worker and I have learned the basic concepts of troubleshooting in my age 6.

So I would be honored to respect my farther on the day of completing my 10 years of the IT experience because he has laid the foundation of my success.

At the same time today is my first anniversary with Exilesoft (Pvt) Ltd.

Wednesday, May 20, 2009

A new trend for IT virtualization by VMware vShpere


About one year ago, I had an imagination of having an enterprise level packet filtering mechanism inbuilt with VMware Infrastructure. Because it will be time saving and it’ll be more sophisticated when you defining security in between virtual infrastructures you build inside your VMware server. Basically what was in my mind is an improved VMware switch (capable of routing and packet filtering) to handle the high end security requirements. And It’s was just another entry to my wish list.

Recently VMware announced its new concept of future IT virtualization, “Cloud Computing” VMware vShpere. It’s a wide solution with high end Security, High availability (fault tolerate, data recovery), Scalability, etc. I’m anxiously waiting to get in touch with this latest technology. It will be released soon.

A simulcast done by VMware CEO Paul Maritz: http://www-waa-akam.thomson-webcast.net/us/dispatching/?event_id=fac15ded614cefc0febbae341bec9c7c&portal_id=dd2b37882b0db9169ba0823a6e235f4e

Monday, February 16, 2009

Loose the ethernet when you moving Ubuntu on VMware ESX ???

Some one can confused because, when you shifting a VM or copy, rename, Vmware asks to update the UUID but when you trying to up the network device you will be seeing something like below,

"SIOCSIFADDR: No such device
eth0: ERROR while getting interface flags: No such device
SIOCSIFADDR: No such device
SIOCSIFADDR: No such device
eth0: ERROR while getting interface flags: No such device
eth0: ERROR while getting interface flags: No such device"





Cause: VMware basses the MAC address of interface on it's internal UUID.

Solution:
Edit /etc/udev/rules.d/70-persistent-net.rules and delete the additional entries if exists and enter the correct MAC address.





Do a restart and the network should be fine.

Friday, February 13, 2009

Cisco Firewall disabling TLS initiation by default

I have found my Cisco ASA 5510 is masking out STARTTLS initiation because of the SMTP packet inspection. This is enabled by default.

How to enable the firewall to start TLS on ESMTP sessions;

Option one;
policy-map type inspect esmtp esmtp_map
parameters
allow-tls [action log]
Option two;
no fixup protocol smtp 25
(fixup command is an obsolete command used in Cisco IOS version 6 and earlier, I'm having IOS 8.0(4) but fixup is working for me too)